Unable to sign in to CoinJar
Incident Report for CoinJar
Resolved
Regular service has now resumed. Thank you for your patience during this brief downtime.
Posted 10 months ago. Jan 22, 2018 - 14:07 AEDT
Investigating
The CoinJar website is currently experiencing some unscheduled downtime. This is being investigated and regular service is expected to resume shortly.
Posted 10 months ago. Jan 22, 2018 - 13:43 AEDT