Delays With Sending Cryptocurrency Payments
Incident Report for CoinJar
Resolved
This incident has been resolved. Please contact support@coinjar.com if you have any issues.
Posted May 19, 2023 - 14:55 AEST
Identified
We're currently investigating an issue that is causing outgoing cryptocurrency payments to experience delays leaving CoinJar accounts.

If you have any questions, please get in touch with CoinJar Support by emailing support@coinjar.com.
Posted May 19, 2023 - 11:15 AEST
This incident affected: Cryptocurrency Payments.