Delays with responding to Support requests
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted May 19, 2021 - 12:26 AEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 21, 2021 - 08:00 AEST
Identified
Over the past few weeks, CoinJar has experienced an immense number of new CoinJar members looking to buy and sell digital currencies due to the recent market fluctuations. This has generated a great deal of Support enquiries, making it difficult to respond to requests in the usual timely manner.

We've since brought in and trained new Support Team members to help regain some lost ground, and we're in the process of expanding our Support Team even further to meet these new demands.

Although we have our full team working to respond to as many Support requests as possible, we're still receiving many new submissions each day. To help ease the congestion, if you have an existing Support request, please avoid raising multiple Support requests for the same issue.

Please accept our apologies for these extensive delays in getting back to you. We will be in touch as soon as we can.
Posted Apr 12, 2021 - 03:30 AEST
This incident affected: CoinJar Support.