Bank withdrawal delays
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 15, 2018 - 14:32 AEDT
Identified
Due to some internal processing issues, certain transfers to linked bank accounts that were made on or after Tuesday, January 23rd have experienced some delays in being sent out. Affected withdrawals may arrive later than our typical 1-3 business day estimated time frame.
Posted 6 months ago. Jan 29, 2018 - 12:11 AEDT