Delayed Bank Withdrawals
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted Jul 02, 2021 - 14:06 AEST
Investigating
We are aware of an issue where AUD withdrawals to linked bank accounts are experiencing prolonged delays from 11:00 AEST. We are working with our payment provider to resolve this issue and appreciate your patience in the meantime.
Posted Jul 01, 2021 - 13:07 AEST
This incident affected: Bank Transfers & Deposits.