ID System Downtime
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 15, 2019 - 13:39 AEDT
Identified
We are currently upgrading our ID system which will prevent the ability to upload new ID documents. This update is currently being worked on and we will provide more updates as they become available.
Posted 8 months ago. Feb 15, 2019 - 11:33 AEDT
This incident affected: CoinJar Website.