Delays with responding to Support requests
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 10:29 AEDT
Identified
Over the past few weeks, CoinJar has experienced an immense number of new CoinJar members looking to buy and sell cryptocurrencies. This has generated a great deal of Support enquiries, making it difficult to respond to requests in the usual timely manner.

Although we have our team working to respond to as many Support requests as possible, we're still receiving many new submissions each day. To help ease the congestion, if you have an existing Support request, please avoid raising multiple Support requests for the same issue.

Please accept our apologies for these extensive delays in getting back to you. We will be in touch as soon as we can.

Our Knowledge Base is available and may help to resolve your query while you wait to hear from us: https://support.coinjar.com/hc/
Posted Mar 18, 2024 - 12:49 AEDT
This incident affected: CoinJar Support.