Swipe card order delays
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 13, 2018 - 17:23 AEDT
Identified
EML Payments Limited - CoinJar's Swipe card provider - has advised their manufacturing process has recently suffered inventory processing issues, which has resulted in delays for all new card orders. Swipe card orders placed between December 6 - December 22 are now expected to arrive some time in mid-to-late January 2018 at the earliest.

Unfortunately, CoinJar is unable to provide any expedited orders during this time - we're having to wait for these manufacturing issues to be resolved. We apologise for the additional wait time while new card orders are being processed. Thank you for your ongoing patience as EML works to send out all orders as soon as possible.
Posted 10 months ago. Dec 15, 2017 - 12:04 AEDT