ID Verification Unplanned Outage

Incident Report for CoinJar

Resolved

ID verification issue has now been resolved.
Posted Jul 11, 2024 - 11:22 AEST

Investigating

We are currently seeing issues with ID verification for Australian CoinJar customers.

Our Engineering Team is actively working on resolving this issue as quickly as possible. We will provide further updates as soon as we receive more information.
Posted Jul 11, 2024 - 11:14 AEST
This incident affected: CoinJar Website and CoinJar for iOS and Android.