Delayed GBP withdrawals
Incident Report for CoinJar
Resolved
This incident has been resolved and a fix has been deployed. All delayed withdrawals have now been successfully processed.

Please contact support@coinjar.com if you need any assistance.
Posted Oct 27, 2023 - 13:57 AEDT
Investigating
We are currently investigating an issue with delayed GBP withdrawals to linked bank accounts. We hope to provide an update as soon as possible. Please contact support@coinjar.com if you have any questions or concerns.
Posted Oct 26, 2023 - 21:49 AEDT
This incident affected: Bank Deposits & Withdrawals.