Delays In Processing SUI Transactions
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 09:12 AEST
Investigating
We're currently investigating an issue that is causing delays in processing SUI transactions.

This affects SUI only - all other digital currency payments are being processed as normal.
Posted Jul 26, 2024 - 15:52 AEST
This incident affected: Cryptocurrency Payments.