Digital Currency payments not being processed
Incident Report for CoinJar
Resolved
Our payment provider BitGo has now resolved this issue and digital currency payments are once again being processed within normal time frames. Thank you for your patience.
Posted 2 months ago. Jun 11, 2019 - 15:06 AEST
Identified
We have identified this to be an issue with our payment provider BitGo. We will provide further updates as they become available.
Posted 2 months ago. Jun 11, 2019 - 13:20 AEST
Update
We have identified this to be an issue with our payment provider BitGo. We will provide further updates as they become available.
Posted 2 months ago. Jun 11, 2019 - 13:20 AEST
Investigating
Both outgoing and incoming Digital Currency payments are currently not being processed.

Our Engineering Team is currently investigating this and we will provide an update soon.
Posted 2 months ago. Jun 11, 2019 - 12:15 AEST
This incident affected: Digital Currency Payments.