Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2025 - 20:00 AEST
Scheduled
Polygon mainnet will perform an upgrade on June 29, 2025, at 10:00 UTC. The upgrade will be completed once the network’s nodes finish upgrading. During that period, the network might be disrupted from time to time.
Posted Jun 26, 2025 - 09:23 AEST
This scheduled maintenance affected: CoinJar Exchange, Cryptocurrency conversions (buying & selling), and Cryptocurrency Payments.