Bank withdrawal delays
Incident Report for CoinJar
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 26, 2018 - 09:07 AEDT
Identified
Due to some unforeseen internal processing issues, transfers to linked bank accounts that were made on or after Saturday, January 20th have experienced some delays in being sent out. These issues have now been resolved and the transfers processed, however affected withdrawals will be arriving later than our typical 1-3 business day estimated time frame.
Posted 10 months ago. Jan 25, 2018 - 16:40 AEDT