CoinJar Rewards Downtime
Incident Report for CoinJar
Resolved
The scheduled maintenance is now completed. Thank you for your patience during this time.
Posted 23 days ago. Aug 26, 2019 - 16:55 AEST
Investigating
CoinJar Rewards will be experiencing some downtime while scheduled maintenance is undertaken.
Posted 23 days ago. Aug 26, 2019 - 15:00 AEST
This incident affected: CoinJar Website.