Bank Withdrawal Delays
Incident Report for CoinJar
Resolved
This incident has been investigated and resolved. Withdrawals to linked bank accounts are being processed as expected.
Posted Oct 17, 2019 - 09:31 AEDT
Investigating
Due to internal processing issues, withdrawals to linked bank accounts that were made after 3:30pm AEDT on Tuesday, October 15th have experienced some delays in being sent out. Affected withdrawals may arrive later than our typical 1-3 business day estimated time frame.
Posted Oct 16, 2019 - 17:53 AEDT
This incident affected: Bank Deposits & Withdrawals.