Unable to Login
Incident Report for CoinJar
Resolved
We have fixed this issue. Thank you for your patience.
Posted 11 months ago. Aug 23, 2017 - 16:36 AEST
Identified
Users are receiving 'Retry later' messages when logging in. We have identified the cause of this issue and are implementing a fix.
Posted 11 months ago. Aug 23, 2017 - 16:18 AEST